Local repo is now a hairball...

classic Classic list List threaded Threaded
19 messages Options
Reply | Threaded
Open this post in threaded view
|

Local repo is now a hairball...

lcampise
Hi, i'm not sure if I've come to the right place.  While i've been using smartGit for a while successfully to share a remote repository with another developer, i thought I'd try again to do a branch for some work i need to put on hold for now... and again, with branching, have created a mess.  I think I just want revert back to having my repo (and my working directories) match the remote -- maybe best to just disregard all my changes (i saved the files off before trying the branch).  So, is there a "force my local to match the remote so i can get back to work" command? Thanks.  -Leon

PS... I clearly need to understand the architecture (and nomenclature!) of Git better, but am now wondering if I need to learn the command line to really grasp what's going on.  Opinions?

Reply | Threaded
Open this post in threaded view
|

Re: Local repo is now a hairball...

jamsham
Hi Leon,

My first thought is you need to Fetch and Rebase, not Fetch and Merge. Merging just creates loops in the graph and makes it difficult to work with.

Command line offers a variety of things that SmartGit does not, such rebase --onto. You don't need it, but it is good to know it.

Git takes a while to get used to. Avoid merge!

Hope that helps.
James

--- In [hidden email], "Leon Campise" <leon@...> wrote:
>
> Hi, i'm not sure if I've come to the right place.  While i've been using smartGit for a while successfully to share a remote repository with another developer, i thought I'd try again to do a branch for some work i need to put on hold for now... and again, with branching, have created a mess.  I think I just want revert back to having my repo (and my working directories) match the remote -- maybe best to just disregard all my changes (i saved the files off before trying the branch).  So, is there a "force my local to match the remote so i can get back to work" command? Thanks.  -Leon
>
> PS... I clearly need to understand the architecture (and nomenclature!) of Git better, but am now wondering if I need to learn the command line to really grasp what's going on.  Opinions?
>


Reply | Threaded
Open this post in threaded view
|

Re: Local repo is now a hairball...

lcampise
Hey thanks for the quick reply and for the direction, and heads up on rebase.  I'm back up and running.  I *think* switching back to the origin was my main missing step keeping me from syncing — I think I was trying to push while on a "non tracking" branch.


From: shamas8 <[hidden email]<mailto:[hidden email]>>
Reply-To: <[hidden email]<mailto:[hidden email]>>
Date: Wed, 1 Feb 2012 06:30:05 +0000
To: <[hidden email]<mailto:[hidden email]>>
Subject: [smartgit] Re: Local repo is now a hairball...



Hi Leon,

My first thought is you need to Fetch and Rebase, not Fetch and Merge. Merging just creates loops in the graph and makes it difficult to work with.

Command line offers a variety of things that SmartGit does not, such rebase --onto. You don't need it, but it is good to know it.

Git takes a while to get used to. Avoid merge!

Hope that helps.
James

--- In [hidden email]<mailto:smartgit%40yahoogroups.com>, "Leon Campise" <leon@...> wrote:
>
> Hi, i'm not sure if I've come to the right place. While i've been using smartGit for a while successfully to share a remote repository with another developer, i thought I'd try again to do a branch for some work i need to put on hold for now... and again, with branching, have created a mess. I think I just want revert back to having my repo (and my working directories) match the remote -- maybe best to just disregard all my changes (i saved the files off before trying the branch). So, is there a "force my local to match the remote so i can get back to work" command? Thanks. -Leon
>
> PS... I clearly need to understand the architecture (and nomenclature!) of Git better, but am now wondering if I need to learn the command line to really grasp what's going on. Opinions?
>





[Non-text portions of this message have been removed]



------------------------------------

Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/smartgit/

<*> Your email settings:
    Individual Email | Traditional

<*> To change settings online go to:
    http://groups.yahoo.com/group/smartgit/join
    (Yahoo! ID required)

<*> To change settings via email:
    [hidden email]
    [hidden email]

<*> To unsubscribe from this group, send an email to:
    [hidden email]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/

Reply | Threaded
Open this post in threaded view
|

Re: Local repo is now a hairball...

Thomas Singer
Administrator
In reply to this post by jamsham
> Command line offers a variety of things that SmartGit does not, such rebase --onto.

rebase onto (aka Rebase HEAD to) is supported by SmartGit.

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com


On 01.02.2012 07:30, shamas8 wrote:

> Hi Leon,
>
> My first thought is you need to Fetch and Rebase, not Fetch and Merge. Merging just creates loops in the graph and makes it difficult to work with.
>
> Command line offers a variety of things that SmartGit does not, such rebase --onto. You don't need it, but it is good to know it.
>
> Git takes a while to get used to. Avoid merge!
>
> Hope that helps.
> James
>
> --- In [hidden email], "Leon Campise"<leon@...>  wrote:
>>
>> Hi, i'm not sure if I've come to the right place.  While i've been using smartGit for a while successfully to share a remote repository with another developer, i thought I'd try again to do a branch for some work i need to put on hold for now... and again, with branching, have created a mess.  I think I just want revert back to having my repo (and my working directories) match the remote -- maybe best to just disregard all my changes (i saved the files off before trying the branch).  So, is there a "force my local to match the remote so i can get back to work" command? Thanks.  -Leon
>>
>> PS... I clearly need to understand the architecture (and nomenclature!) of Git better, but am now wondering if I need to learn the command line to really grasp what's going on.  Opinions?
Reply | Threaded
Open this post in threaded view
|

Re: Local repo is now a hairball...

Andrew Herron
In reply to this post by lcampise

> So, is there a "force my local to match the remote so i can get back to work" command? Thanks. -Leon
It's git, there's a command for everything ;)

git reset --hard origin/master (or replace master with the appropriate branch name) is what you were after here. it will blow away everything not pushed up to origin/master. This is useful if you commit a bunch of things and then decide they're all useless.

git checkout -- . and git clean -fd are also useful for getting rid of uncommitted things without deleting any commits.

> PS... I clearly need to understand the architecture (and nomenclature!) of Git better, but am now wondering if I need to learn the command line to really grasp what's going on. Opinions?
I found this article really helpful to understand what git does:
http://nfarina.com/post/9868516270/git-is-simpler

Once you realise that git is just a bunch of shell scripts, and that it never actually deletes anything, you can start to understand how to recover from mistakes which will make you much more confident in experimentation :)

I also recommend this one to understand not only which commands lie, but when you are safe to lie to fix mistakes and when lying will break every other clone of your repository:
http://paul.stadig.name/2010/12/thou-shalt-not-lie-git-rebase-ammend.html

Cheers,
Andy


[Non-text portions of this message have been removed]

Reply | Threaded
Open this post in threaded view
|

Re: Local repo is now a hairball...

jamsham
In reply to this post by Thomas Singer


--- In [hidden email], Thomas Singer <thomas.singer@...> wrote:
>
> > Command line offers a variety of things that SmartGit does not, such rebase --onto.
>
> rebase onto (aka Rebase HEAD to) is supported by SmartGit.

Rebase HEAD to is equivalent to 'git rebase foo'
'git rebase --onto foo a43414 bar' is a different thing. SmartGit does not support it, nor should it! This is only one example, there are many complex things you can do in git that is beyond the recommended scope of SmartGit

>
> --
> Best regards,
> Thomas Singer
> =============
> syntevo GmbH
> http://www.syntevo.com
> http://blog.syntevo.com
>
>
> On 01.02.2012 07:30, shamas8 wrote:
> > Hi Leon,
> >
> > My first thought is you need to Fetch and Rebase, not Fetch and Merge. Merging just creates loops in the graph and makes it difficult to work with.
> >
> > Command line offers a variety of things that SmartGit does not, such rebase --onto. You don't need it, but it is good to know it.
> >
> > Git takes a while to get used to. Avoid merge!
> >
> > Hope that helps.
> > James
> >
> > --- In [hidden email], "Leon Campise"<leon@>  wrote:
> >>
> >> Hi, i'm not sure if I've come to the right place.  While i've been using smartGit for a while successfully to share a remote repository with another developer, i thought I'd try again to do a branch for some work i need to put on hold for now... and again, with branching, have created a mess.  I think I just want revert back to having my repo (and my working directories) match the remote -- maybe best to just disregard all my changes (i saved the files off before trying the branch).  So, is there a "force my local to match the remote so i can get back to work" command? Thanks.  -Leon
> >>
> >> PS... I clearly need to understand the architecture (and nomenclature!) of Git better, but am now wondering if I need to learn the command line to really grasp what's going on.  Opinions?
>


Reply | Threaded
Open this post in threaded view
|

Re: Local repo is now a hairball...

syntevo Support
In reply to this post by lcampise
Leon, did you read the quick-start-guide bundled with SmartGit?

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com


02/01/2012 07:10 - Leon Campise wrote:

> Hi, i'm not sure if I've come to the right place.  While i've been using smartGit
> for a while successfully to share a remote repository with another developer, i
> thought I'd try again to do a branch for some work i need to put on hold for
> now... and again, with branching, have created a mess.  I think I just want revert
> back to having my repo (and my working directories) match the remote -- maybe best
> to just disregard all my changes (i saved the files off before trying the branch).
>  So, is there a "force my local to match the remote so i can get back to work"
> command? Thanks.  -Leon
>
> PS... I clearly need to understand the architecture (and nomenclature!) of Git
> better, but am now wondering if I need to learn the command line to really grasp
> what's going on.  Opinions?
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Local repo is now a hairball...

syntevo Support
In reply to this post by jamsham
Your are right. "Rebase to HEAD" in the project window can execute following
Git command (two commits selected):

git rebase --onto <current-branch> <from-commit> <to-commit>

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com


On 02.02.2012 00:13, shamas8 wrote:

>
>
> --- In [hidden email], Thomas Singer <thomas.singer@...> wrote:
>>
>>> Command line offers a variety of things that SmartGit does not, such rebase --onto.
>>
>> rebase onto (aka Rebase HEAD to) is supported by SmartGit.
>
> Rebase HEAD to is equivalent to 'git rebase foo'
> 'git rebase --onto foo a43414 bar' is a different thing. SmartGit does not support it, nor should it! This is only one example, there are many complex things you can do in git that is beyond the recommended scope of SmartGit
>
>>
>> --
>> Best regards,
>> Thomas Singer
>> =============
>> syntevo GmbH
>> http://www.syntevo.com
>> http://blog.syntevo.com
>>
>>
>> On 01.02.2012 07:30, shamas8 wrote:
>>> Hi Leon,
>>>
>>> My first thought is you need to Fetch and Rebase, not Fetch and Merge. Merging just creates loops in the graph and makes it difficult to work with.
>>>
>>> Command line offers a variety of things that SmartGit does not, such rebase --onto. You don't need it, but it is good to know it.
>>>
>>> Git takes a while to get used to. Avoid merge!
>>>
>>> Hope that helps.
>>> James
>>>
>>> --- In [hidden email], "Leon Campise"<leon@>  wrote:
>>>>
>>>> Hi, i'm not sure if I've come to the right place.  While i've been using smartGit for a while successfully to share a remote repository with another developer, i thought I'd try again to do a branch for some work i need to put on hold for now... and again, with branching, have created a mess.  I think I just want revert back to having my repo (and my working directories) match the remote -- maybe best to just disregard all my changes (i saved the files off before trying the branch).  So, is there a "force my local to match the remote so i can get back to work" command? Thanks.  -Leon
>>>>
>>>> PS... I clearly need to understand the architecture (and nomenclature!) of Git better, but am now wondering if I need to learn the command line to really grasp what's going on.  Opinions?
>>
>
>
>
>
> ------------------------------------
>
> Yahoo! Groups Links
>
>
>
>
Reply | Threaded
Open this post in threaded view
|

EA11 bug found

Alexander Golyshkin
Hi,

I have observed that EA11 for Linux doesn't show submitter picture in log view. The same version for windows works correctly. Could you fix it in next EA versions?  


[Non-text portions of this message have been removed]

Reply | Threaded
Open this post in threaded view
|

Re: EA11 bug found

syntevo Support
How is this related to the hairball repository?

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com


02/04/2012 10:20 - Alexander Golyshkin wrote:

> Hi,
>
> I have observed that EA11 for Linux doesn't show submitter picture in log view.
> The same version for windows works correctly. Could you fix it in next EA
> versions?  
>
>
> [Non-text portions of this message have been removed]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: EA11 bug found

Alexander Golyshkin
Hi Thomas,

It's not related to hairball repo 8) Its just related to common usability under Linux and would be great if you will fix it in future.


________________________________
 From: syntevo Support <[hidden email]>
To: [hidden email]
Sent: Saturday, February 4, 2012 3:30 PM
Subject: Re: [smartgit] EA11 bug found
 

 
How is this related to the hairball repository?

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com

02/04/2012 10:20 - Alexander Golyshkin wrote:

> Hi,
>
> I have observed that EA11 for Linux doesn't show submitter picture in log view.
> The same version for windows works correctly. Could you fix it in next EA
> versions?  
>
>
> [Non-text portions of this message have been removed]
>
>

 

[Non-text portions of this message have been removed]

Reply | Threaded
Open this post in threaded view
|

Re: EA11 bug found

syntevo Support
I can't reproduce your reported problem on Ubuntu. Maybe you disabled the use of gravatar in the preferences or there are network problems?

> It's not related to hairball repo 8)

Then please create a new message next time instead of replying to a different one.

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com


02/04/2012 18:30 - Alexander Golyshkin wrote:

> Hi Thomas,
>
> It's not related to hairball repo 8) Its just related to common usability under
> Linux and would be great if you will fix it in future.
>
>
> ________________________________
>  From: syntevo Support <[hidden email]>
> To: [hidden email]
> Sent: Saturday, February 4, 2012 3:30 PM
> Subject: Re: [smartgit] EA11 bug found
>  
>
>  
> How is this related to the hairball repository?
>
> --
> Best regards,
> Thomas Singer
> =============
> syntevo GmbH
> http://www.syntevo.com
> http://blog.syntevo.com
>
> 02/04/2012 10:20 - Alexander Golyshkin wrote:
>
> > Hi,
> >
> > I have observed that EA11 for Linux doesn't show submitter picture in log view.
> > The same version for windows works correctly. Could you fix it in next EA
> > versions?  
> >
> >
> > [Non-text portions of this message have been removed]
> >
> >
>
>  
>
> [Non-text portions of this message have been removed]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: EA11 bug found

Alexander Golyshkin
Hi Thomas,

It's very strange 8( Linux EA12 is also doesn't display gravatar icons. Corresponding checkbox in settings enabled. No issues with network - checked. SmartGit also is able to see new versions on clicking "Check new versions" button.



________________________________
 From: syntevo Support <[hidden email]>
To: [hidden email]
Sent: Sunday, February 5, 2012 1:11 PM
Subject: Re: [smartgit] EA11 bug found
 

 
I can't reproduce your reported problem on Ubuntu. Maybe you disabled the use of gravatar in the preferences or there are network problems?

> It's not related to hairball repo 8)

Then please create a new message next time instead of replying to a different one.

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com

02/04/2012 18:30 - Alexander Golyshkin wrote:

> Hi Thomas,
>
> It's not related to hairball repo 8) Its just related to common usability under
> Linux and would be great if you will fix it in future.
>
>
> ________________________________
>  From: syntevo Support <[hidden email]>
> To: [hidden email]
> Sent: Saturday, February 4, 2012 3:30 PM
> Subject: Re: [smartgit] EA11 bug found
>
>
>  
> How is this related to the hairball repository?
>
> --
> Best regards,
> Thomas Singer
> =============
> syntevo GmbH
> http://www.syntevo.com
> http://blog.syntevo.com
>
> 02/04/2012 10:20 - Alexander Golyshkin wrote:
>
> > Hi,
> >
> > I have observed that EA11 for Linux doesn't show submitter picture in log view.
> > The same version for windows works correctly. Could you fix it in next EA
> > versions?  
> >
> >
> > [Non-text portions of this message have been removed]
> >
> >
>
>
>
> [Non-text portions of this message have been removed]
>
>

 

[Non-text portions of this message have been removed]

Reply | Threaded
Open this post in threaded view
|

Re: EA11 bug found

syntevo Support
Do you have a proxy? What's with SmartGit 2.1 - does the gravatars work there?

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com


02/07/2012 09:10 - Alexander Golyshkin wrote:

> Hi Thomas,
>
> It's very strange 8( Linux EA12 is also doesn't display gravatar icons.
> Corresponding checkbox in settings enabled. No issues with network - checked.
> SmartGit also is able to see new versions on clicking "Check new versions" button.
>
>
>
> ________________________________
>  From: syntevo Support <[hidden email]>
> To: [hidden email]
> Sent: Sunday, February 5, 2012 1:11 PM
> Subject: Re: [smartgit] EA11 bug found
>  
>
>  
> I can't reproduce your reported problem on Ubuntu. Maybe you disabled the use of
> gravatar in the preferences or there are network problems?
>
> > It's not related to hairball repo 8)
>
> Then please create a new message next time instead of replying to a different one.
>
> --
> Best regards,
> Thomas Singer
> =============
> syntevo GmbH
> http://www.syntevo.com
> http://blog.syntevo.com
>
> 02/04/2012 18:30 - Alexander Golyshkin wrote:
>
> > Hi Thomas,
> >
> > It's not related to hairball repo 8) Its just related to common usability under
> > Linux and would be great if you will fix it in future.
> >
> >
> > ________________________________
> >  From: syntevo Support <[hidden email]>
> > To: [hidden email]
> > Sent: Saturday, February 4, 2012 3:30 PM
> > Subject: Re: [smartgit] EA11 bug found
> >
> >
> >  
> > How is this related to the hairball repository?
> >
> > --
> > Best regards,
> > Thomas Singer
> > =============
> > syntevo GmbH
> > http://www.syntevo.com
> > http://blog.syntevo.com
> >
> > 02/04/2012 10:20 - Alexander Golyshkin wrote:
> >
> > > Hi,
> > >
> > > I have observed that EA11 for Linux doesn't show submitter picture in log view.
> > > The same version for windows works correctly. Could you fix it in next EA
> > > versions?  
> > >
> > >
> > > [Non-text portions of this message have been removed]
> > >
> > >
> >
> >
> >
> > [Non-text portions of this message have been removed]
> >
> >
>
>  
>
> [Non-text portions of this message have been removed]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: EA11 bug found

Alexander Golyshkin
In reply to this post by Alexander Golyshkin
Hi Thomas,

I have checked SmartGit 2.1.6 and avatars also doesn't work in LOG VIEW on Linux version. I am sure that there is no problem with connections, since update working fine.

Note: Linux SmartGit 3 RC1 also doesn't support this feature



________________________________
 From: Alexander Golyshkin <[hidden email]>
To: "[hidden email]" <[hidden email]>
Sent: Tuesday, February 7, 2012 12:07 PM
Subject: Re: [smartgit] EA11 bug found
 

Hi Thomas,

It's very strange 8( Linux EA12 is also doesn't display gravatar icons. Corresponding checkbox in settings enabled. No issues with network - checked. SmartGit also is able to see new versions on clicking "Check new versions" button.



________________________________
 From: syntevo Support <[hidden email]>
To: [hidden email]
Sent: Sunday, February 5, 2012 1:11 PM
Subject: Re: [smartgit] EA11 bug found
 

 
I can't reproduce your reported problem on Ubuntu. Maybe you disabled the use of gravatar in the preferences or there are network problems?

> It's not related to hairball repo 8)

Then please create a new message next time instead of replying to a different one.

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com

02/04/2012 18:30 - Alexander Golyshkin wrote:

> Hi Thomas,
>
> It's not related to hairball repo 8) Its just related to common usability under
> Linux and would be great if you will fix it in future.
>
>
> ________________________________
>  From: syntevo Support <[hidden email]>
> To: [hidden email]
> Sent: Saturday, February 4, 2012 3:30 PM
> Subject: Re: [smartgit] EA11 bug found
>
>
>  
> How is this related to the hairball repository?
>
> --
> Best regards,
> Thomas Singer
> =============
> syntevo GmbH
> http://www.syntevo.com
> http://blog.syntevo.com
>
> 02/04/2012 10:20 - Alexander Golyshkin wrote:
>
> > Hi,
> >
> > I have observed that EA11 for Linux doesn't show submitter picture in log view.
> > The same version for windows works correctly. Could you fix it in next EA
> > versions?  
> >
> >
> > [Non-text portions of this message have been removed]
> >
> >
>
>
>
> [Non-text portions of this message have been removed]
>
>

 

[Non-text portions of this message have been removed]

Reply | Threaded
Open this post in threaded view
|

Re: EA11 bug found

syntevo Support
Do you have a proxy configured on your system? Is there some useful exception in the log.txt?

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com


02/15/2012 09:50 - Alexander Golyshkin wrote:

> Hi Thomas,
>
> I have checked SmartGit 2.1.6 and avatars also doesn't work in LOG VIEW on Linux
> version. I am sure that there is no problem with connections, since update working
> fine.
>
> Note: Linux SmartGit 3 RC1 also doesn't support this feature
>
>
>
> ________________________________
>  From: Alexander Golyshkin <[hidden email]>
> To: "[hidden email]" <[hidden email]>
> Sent: Tuesday, February 7, 2012 12:07 PM
> Subject: Re: [smartgit] EA11 bug found
>  
>
> Hi Thomas,
>
> It's very strange 8( Linux EA12 is also doesn't display gravatar icons.
> Corresponding checkbox in settings enabled. No issues with network - checked.
> SmartGit also is able to see new versions on clicking "Check new versions" button.
>
>
>
> ________________________________
>  From: syntevo Support <[hidden email]>
> To: [hidden email]
> Sent: Sunday, February 5, 2012 1:11 PM
> Subject: Re: [smartgit] EA11 bug found
>  
>
>  
> I can't reproduce your reported problem on Ubuntu. Maybe you disabled the use of
> gravatar in the preferences or there are network problems?
>
> > It's not related to hairball repo 8)
>
> Then please create a new message next time instead of replying to a different one.
>
> --
> Best regards,
> Thomas Singer
> =============
> syntevo GmbH
> http://www.syntevo.com
> http://blog.syntevo.com
>
> 02/04/2012 18:30 - Alexander Golyshkin wrote:
>
> > Hi Thomas,
> >
> > It's not related to hairball repo 8) Its just related to common usability under
> > Linux and would be great if you will fix it in future.
> >
> >
> > ________________________________
> >  From: syntevo Support <[hidden email]>
> > To: [hidden email]
> > Sent: Saturday, February 4, 2012 3:30 PM
> > Subject: Re: [smartgit] EA11 bug found
> >
> >
> >  
> > How is this related to the hairball repository?
> >
> > --
> > Best regards,
> > Thomas Singer
> > =============
> > syntevo GmbH
> > http://www.syntevo.com
> > http://blog.syntevo.com
> >
> > 02/04/2012 10:20 - Alexander Golyshkin wrote:
> >
> > > Hi,
> > >
> > > I have observed that EA11 for Linux doesn't show submitter picture in log view.
> > > The same version for windows works correctly. Could you fix it in next EA
> > > versions?  
> > >
> > >
> > > [Non-text portions of this message have been removed]
> > >
> > >
> >
> >
> >
> > [Non-text portions of this message have been removed]
> >
> >
>
>  
>
> [Non-text portions of this message have been removed]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: EA11 bug found

Alexander Golyshkin
Hi,

Yes, I have a proxy. Looks proxy working fine, because I can check updates in smartgit, but avatars still not available! The same version for windows with the same proxy config working fine! What is a problem?

Regards,
Alexander Golyshkin

15.02.2012, × 11:58, syntevo Support <[hidden email]> ÎÁÐÉÓÁÌ(Á):

> Do you have a proxy configured on your system? Is there some useful exception in the log.txt?
>
> --
> Best regards,
> Thomas Singer
> =============
> syntevo GmbH
> http://www.syntevo.com
> http://blog.syntevo.com
>
> 02/15/2012 09:50 - Alexander Golyshkin wrote:
>
> > Hi Thomas,
> >
> > I have checked SmartGit 2.1.6 and avatars also doesn't work in LOG VIEW on Linux
> > version. I am sure that there is no problem with connections, since update working
> > fine.
> >
> > Note: Linux SmartGit 3 RC1 also doesn't support this feature
> >
> >
> >
> > ________________________________
> > From: Alexander Golyshkin <[hidden email]>
> > To: "[hidden email]" <[hidden email]>
> > Sent: Tuesday, February 7, 2012 12:07 PM
> > Subject: Re: [smartgit] EA11 bug found
> >
> >
> > Hi Thomas,
> >
> > It's very strange 8( Linux EA12 is also doesn't display gravatar icons.
> > Corresponding checkbox in settings enabled. No issues with network - checked.
> > SmartGit also is able to see new versions on clicking "Check new versions" button.
> >
> >
> >
> > ________________________________
> > From: syntevo Support <[hidden email]>
> > To: [hidden email]
> > Sent: Sunday, February 5, 2012 1:11 PM
> > Subject: Re: [smartgit] EA11 bug found
> >
> >
> >  
> > I can't reproduce your reported problem on Ubuntu. Maybe you disabled the use of
> > gravatar in the preferences or there are network problems?
> >
> > > It's not related to hairball repo 8)
> >
> > Then please create a new message next time instead of replying to a different one.
> >
> > --
> > Best regards,
> > Thomas Singer
> > =============
> > syntevo GmbH
> > http://www.syntevo.com
> > http://blog.syntevo.com
> >
> > 02/04/2012 18:30 - Alexander Golyshkin wrote:
> >
> > > Hi Thomas,
> > >
> > > It's not related to hairball repo 8) Its just related to common usability under
> > > Linux and would be great if you will fix it in future.
> > >
> > >
> > > ________________________________
> > > From: syntevo Support <[hidden email]>
> > > To: [hidden email]
> > > Sent: Saturday, February 4, 2012 3:30 PM
> > > Subject: Re: [smartgit] EA11 bug found
> > >
> > >
> > >  
> > > How is this related to the hairball repository?
> > >
> > > --
> > > Best regards,
> > > Thomas Singer
> > > =============
> > > syntevo GmbH
> > > http://www.syntevo.com
> > > http://blog.syntevo.com
> > >
> > > 02/04/2012 10:20 - Alexander Golyshkin wrote:
> > >
> > > > Hi,
> > > >
> > > > I have observed that EA11 for Linux doesn't show submitter picture in log view.
> > > > The same version for windows works correctly. Could you fix it in next EA
> > > > versions?  
> > > >
> > > >
> > > > [Non-text portions of this message have been removed]
> > > >
> > > >
> > >
> > >
> > >
> > > [Non-text portions of this message have been removed]
> > >
> > >
> >
> >
> >
> > [Non-text portions of this message have been removed]
> >
> >
>


[Non-text portions of this message have been removed]



------------------------------------

Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/smartgit/

<*> Your email settings:
    Individual Email | Traditional

<*> To change settings online go to:
    http://groups.yahoo.com/group/smartgit/join
    (Yahoo! ID required)

<*> To change settings via email:
    [hidden email]
    [hidden email]

<*> To unsubscribe from this group, send an email to:
    [hidden email]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/

Reply | Threaded
Open this post in threaded view
|

Re: gravatars and proxy

syntevo Support
Please try the latest intermediate build from

http://www.syntevo.com/smartgit/intermediate-eap-builds.html

and let me know whether this solves the problem. Thanks in advance.

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com


02/18/2012 06:40 - Alexander Golyshkin wrote:

> Hi,
>
> Yes, I have a proxy. Looks proxy working fine, because I can check updates in
> smartgit, but avatars still not available! The same version for windows with the
> same proxy config working fine! What is a problem?
>
> Regards,
> Alexander Golyshkin
>
> 15.02.2012, × 11:58, syntevo Support <[hidden email]> ÎÁÐÉÓÁÌ(Á):
>
> > Do you have a proxy configured on your system? Is there some useful exception in the log.txt?
> >
> > --
> > Best regards,
> > Thomas Singer
> > =============
> > syntevo GmbH
> > http://www.syntevo.com
> > http://blog.syntevo.com
> >
> > 02/15/2012 09:50 - Alexander Golyshkin wrote:
> >
> > > Hi Thomas,
> > >
> > > I have checked SmartGit 2.1.6 and avatars also doesn't work in LOG VIEW on Linux
> > > version. I am sure that there is no problem with connections, since update working
> > > fine.
> > >
> > > Note: Linux SmartGit 3 RC1 also doesn't support this feature
> > >
> > >
> > >
> > > ________________________________
> > > From: Alexander Golyshkin <[hidden email]>
> > > To: "[hidden email]" <[hidden email]>
> > > Sent: Tuesday, February 7, 2012 12:07 PM
> > > Subject: Re: [smartgit] EA11 bug found
> > >
> > >
> > > Hi Thomas,
> > >
> > > It's very strange 8( Linux EA12 is also doesn't display gravatar icons.
> > > Corresponding checkbox in settings enabled. No issues with network - checked.
> > > SmartGit also is able to see new versions on clicking "Check new versions" button.
> > >
> > >
> > >
> > > ________________________________
> > > From: syntevo Support <[hidden email]>
> > > To: [hidden email]
> > > Sent: Sunday, February 5, 2012 1:11 PM
> > > Subject: Re: [smartgit] EA11 bug found
> > >
> > >
> > >  
> > > I can't reproduce your reported problem on Ubuntu. Maybe you disabled the use of
> > > gravatar in the preferences or there are network problems?
> > >
> > > > It's not related to hairball repo 8)
> > >
> > > Then please create a new message next time instead of replying to a different one.
> > >
> > > --
> > > Best regards,
> > > Thomas Singer
> > > =============
> > > syntevo GmbH
> > > http://www.syntevo.com
> > > http://blog.syntevo.com
> > >
> > > 02/04/2012 18:30 - Alexander Golyshkin wrote:
> > >
> > > > Hi Thomas,
> > > >
> > > > It's not related to hairball repo 8) Its just related to common usability under
> > > > Linux and would be great if you will fix it in future.
> > > >
> > > >
> > > > ________________________________
> > > > From: syntevo Support <[hidden email]>
> > > > To: [hidden email]
> > > > Sent: Saturday, February 4, 2012 3:30 PM
> > > > Subject: Re: [smartgit] EA11 bug found
> > > >
> > > >
> > > >  
> > > > How is this related to the hairball repository?
> > > >
> > > > --
> > > > Best regards,
> > > > Thomas Singer
> > > > =============
> > > > syntevo GmbH
> > > > http://www.syntevo.com
> > > > http://blog.syntevo.com
> > > >
> > > > 02/04/2012 10:20 - Alexander Golyshkin wrote:
> > > >
> > > > > Hi,
> > > > >
> > > > > I have observed that EA11 for Linux doesn't show submitter picture in log view.
> > > > > The same version for windows works correctly. Could you fix it in next EA
> > > > > versions?  
> > > > >
> > > > >
> > > > > [Non-text portions of this message have been removed]
> > > > >
> > > > >
> > > >
> > > >
> > > >
> > > > [Non-text portions of this message have been removed]
> > > >
> > > >
> > >
> > >
> > >
> > > [Non-text portions of this message have been removed]
> > >
> > >
> >
>
>
> [Non-text portions of this message have been removed]
>
>
>
> ------------------------------------
>
> Yahoo! Groups Links
>
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: gravatars and proxy

Alexander Golyshkin
Hi Thomas,

Yes, problem was solved in SmartGit RC3. Thank you!



________________________________
 From: syntevo Support <[hidden email]>
To: [hidden email]
Sent: Sunday, February 19, 2012 3:02 PM
Subject: Re: [smartgit] gravatars and proxy
 

 
Please try the latest intermediate build from

http://www.syntevo.com/smartgit/intermediate-eap-builds.html

and let me know whether this solves the problem. Thanks in advance.

--
Best regards,
Thomas Singer
=============
syntevo GmbH
http://www.syntevo.com
http://blog.syntevo.com

02/18/2012 06:40 - Alexander Golyshkin wrote:

> Hi,
>
> Yes, I have a proxy. Looks proxy working fine, because I can check updates in
> smartgit, but avatars still not available! The same version for windows with the
> same proxy config working fine! What is a problem?
>
> Regards,
> Alexander Golyshkin
>
> 15.02.2012, × 11:58, syntevo Support <[hidden email]> ÎÁÐÉÓÁÌ(Á):
>
> > Do you have a proxy configured on your system? Is there some useful exception in the log.txt?
> >
> > --
> > Best regards,
> > Thomas Singer
> > =============
> > syntevo GmbH
> > http://www.syntevo.com
> > http://blog.syntevo.com
> >
> > 02/15/2012 09:50 - Alexander Golyshkin wrote:
> >
> > > Hi Thomas,
> > >
> > > I have checked SmartGit 2.1.6 and avatars also doesn't work in LOG VIEW on Linux
> > > version. I am sure that there is no problem with connections, since update working
> > > fine.
> > >
> > > Note: Linux SmartGit 3 RC1 also doesn't support this feature
> > >
> > >
> > >
> > > ________________________________
> > > From: Alexander Golyshkin <[hidden email]>
> > > To: "[hidden email]" <[hidden email]>
> > > Sent: Tuesday, February 7, 2012 12:07 PM
> > > Subject: Re: [smartgit] EA11 bug found
> > >
> > >
> > > Hi Thomas,
> > >
> > > It's very strange 8( Linux EA12 is also doesn't display gravatar icons.
> > > Corresponding checkbox in settings enabled. No issues with network - checked.
> > > SmartGit also is able to see new versions on clicking "Check new versions" button.
> > >
> > >
> > >
> > > ________________________________
> > > From: syntevo Support <[hidden email]>
> > > To: [hidden email]
> > > Sent: Sunday, February 5, 2012 1:11 PM
> > > Subject: Re: [smartgit] EA11 bug found
> > >
> > >
> > >
> > > I can't reproduce your reported problem on Ubuntu. Maybe you disabled the use of
> > > gravatar in the preferences or there are network problems?
> > >
> > > > It's not related to hairball repo 8)
> > >
> > > Then please create a new message next time instead of replying to a different one.
> > >
> > > --
> > > Best regards,
> > > Thomas Singer
> > > =============
> > > syntevo GmbH
> > > http://www.syntevo.com
> > > http://blog.syntevo.com
> > >
> > > 02/04/2012 18:30 - Alexander Golyshkin wrote:
> > >
> > > > Hi Thomas,
> > > >
> > > > It's not related to hairball repo 8) Its just related to common usability under
> > > > Linux and would be great if you will fix it in future.
> > > >
> > > >
> > > > ________________________________
> > > > From: syntevo Support <[hidden email]>
> > > > To: [hidden email]
> > > > Sent: Saturday, February 4, 2012 3:30 PM
> > > > Subject: Re: [smartgit] EA11 bug found
> > > >
> > > >
> > > >
> > > > How is this related to the hairball repository?
> > > >
> > > > --
> > > > Best regards,
> > > > Thomas Singer
> > > > =============
> > > > syntevo GmbH
> > > > http://www.syntevo.com
> > > > http://blog.syntevo.com
> > > >
> > > > 02/04/2012 10:20 - Alexander Golyshkin wrote:
> > > >
> > > > > Hi,
> > > > >
> > > > > I have observed that EA11 for Linux doesn't show submitter picture in log view.
> > > > > The same version for windows works correctly. Could you fix it in next EA
> > > > > versions?
> > > > >
> > > > >
> > > > > [Non-text portions of this message have been removed]
> > > > >
> > > > >
> > > >
> > > >
> > > >
> > > > [Non-text portions of this message have been removed]
> > > >
> > > >
> > >
> > >
> > >
> > > [Non-text portions of this message have been removed]
> > >
> > >
> >
>
>
> [Non-text portions of this message have been removed]
>
>
>
> ------------------------------------
>
> Yahoo! Groups Links
>
>
>
>

 

[Non-text portions of this message have been removed]